members.png
Aug 1

Problem: app connecting to K2 - SOLVED

5 comments

Edited: Aug 3

Hi.

I bough my k2 in November, but only last month I was able to mount it on the bike!

BUT

Although it seems to boot, I'm not able to connect to it.

I've got a 2017 BMW R1200GS.

I've got it working through a FuzeBlock FZ-1 (power from battery, and switched power from bike's accessory fuse). Switched power is working properly with ignition on, and it goes off half a minute later when ignition is turned off, as per bike.

When I turn ignition on the unit boots and I can see it's wifi.

I can connect to it without an issue; I get IP address, so all seems good (first tries I had the phone's 3G data still connected, but as per other's experiences, I turned the Data off).

Nevertheless, the app says it's not connected to the K2, so I can't do a thing.

I'm using the 128G Sandisk supplied at the same time as the K2; I've already saved the new firmware bin files in it, but the DVR doesn't load 'em.

I need some help...

Regards,

 

PS: Phone is running Android 9 (it's a Xiaomi Mi A2, so a pure Android phone - no manufacturer's junk)

 

 

 

 

This morning I had some improvements (but I still can't make the app connect to the K2).

I used my laptop to connect to the k2's wifi, and was able - through the http commands documented somewhere else in the forum - to verify:

* firmware version is 39

* SD Card was not correctly formatted (the folder "INNOVV K2" was not created); I was able to send the format command and now it is recognized:

 

Although the phone connects to it, the app still doesn't recognize the wifi network to the K2 as beeing established, but at least I believe that I can now upgrade the firmware.

As the SD card is not easily accessible, can I use the "upload files" button in the pic above to upload the "k2.bin" file of the v57 version and reboot the unit in order to upgrade it?

 

Thanks in advance,

 

Aug 2

 

As the SD card is not easily accessible, can I use the "upload  files" button in the pic above to upload the "k2.bin" file of the v57  version and reboot the unit in order to upgrade it?

 

Yes. That works.

Aug 3Edited: Aug 5

OK, I've got all working now!

 

So, to recap:

* K2 wifi broadcasting

* app didn't connect to K2 claiming phone's network not connected

* Android 9 phone in either airplane mode with WIFI on or as usual (both cases, connected to K2's wifi network)

* 128G SD card

 

Steps done from the laptop - could be done from the phone (require to open a browser after connecting to the k2's network)

 

0) Power up the unit :) either on the bike or on the bench (follow INNOVV's instructions)

 

1) check if k2 is responding correctly

 

http://192.168.1.254/?custom=1&cmd=3012

Showed firmware version 39

 

http://192.168.1.254/

Didn't show any folder; there should be a "INNOVV_K2" folder

 

 

2) correctly format SD card

 

http://192.168.1.254/?custom=1&cmd=3010&par=1

wait until you can :) . If you have direct view to the unit, you can control the red "photo" light blinking

 

3) upgrade the firmware

a) Go to INNOVV's site, menu support, k2

b) follow instructions and download the latest and greatest K2 firmware (mine was v57)

c) open the following address, and using the first 2 buttons, select the k2.bin file you've just downloaded (first button), and upload it (second button)

http://192.168.1.254/

4) reboot the unit

Just power down the unit's power wait a few seconds and power it up again.

Read the upgrade process in the support pages, and compare to your light sequence (red should blink for a while)

 

5) connect app to K2

a) turn airplane on

b) turn wifi on

c) turn location on (no need to have a gps lock)

d) connect to K2's wifi network

e) call application

 

It worked for me, was based on others partial trials and experiments, so here it goes for anyone that may be in the same boat.

 

Regards

Thank you sharing such solid experience. It is helpful.

New Posts
  • @Michael Williams asked in in another thread where we are all from. I am interested in this, too. But as we should not spam a thread about a technical problem with off-topic posting, I decided that is would be better to create a separate thread for this. So here it is and everybody is invited to tell us where he/she is from and show us how international this forum is. I am located in a small city beside Duesseldorf, Germany, and riding a Tiger 1200 XRT.
  • Had the K2 for 5 days now. Overall its pretty good. I have a few issues that I need to look into. 1 - The lens seems to black out in the bottom (say 4 and 8 O'Clock) A bit like the lens has Glaucoma... 2 - I start my bike, put helmet, gloves on, ride off, but recording doesn't start until I am a few miles away, has to be at least 5 minutes after setting off, and maybe 6 minutes after starting the bike. An I supposed to wais 6 minutes before setting off? 3 - I have to do something with how I transfer the files, WiFi just doesn't cut it. My bike (R1250GS Adventure) automatically powers off after X minutes, not sure exactly how many, to preserve the battery, the WiFi hasn't managed to transfer a 3 minute file before the bike powers off. I cant view from the bike, stream, as it doesn't stream, it just jitters from frame to frame. I have an iPhone XS Max if that makes any difference. So far I have not been able to download or view any recording, only when setting up on live view. On the plus side, it only took 30 minutes to set up on the bike, only having to remove the tank panel. Does anyone have any thoughts on my three issues?
  • After the firmware v61 update, I noticed the blue light on the power transformer never goes off - no matter how long the bike is off. Is this normal? What could possibly be powering this other than my battery?
© INNOVV TECH CO., LTD @ 2013~2019
  • w-tbird
  • w-facebook
  • w-googleplus