members.png
May 10

Issues During v0.49 Firmware Upgrade

3 comments

New K2 owner here. I ran into some hiccups with my K2 yesterday so wanted to share my experience here in case it may benefit another new user.

 

I received my K2 a week ago but am waiting for some add'l items before I installed it. In the meantime, I was getting familiar with the devices and capabilities and iPhone interface. I had the device plugged in to my Windows 10 computer via the USB connection, and although I could not see the device in File Explorer, I could log in via both my phone and PC when connected via WiFi. So all looked normal.

 

Yesterday I was reviewing the recent posts on firmware (bit rates and USB connections). When I went into the app I noticed the DVR was running the v0.39 firmware. Since both the v0.48 and v0.49 were posted to the web site, I decided to upgrade. After reviewing the upgrade procedures, I copied the v0.49 firmware to my SD card (Silicon Power 64GB High Speed MicroSD). The firmware appeared to load correctly according to the observed lights (red photo LED flashing intermittently). But then I had big problems; here were my symptoms:

 

When on USB power:

- DVR boots, but green video LED flashes quickly, indicating it doesn't recognize SD card, even though it is present. But I can see the card in Windows Explorer as a new drive.

- WiFi network is not available

- With front or both cameras plugged in, I can see SD card in Windows Explorer, but if I only plug in rear camera, the DVR appears to continuously reboot.

 

Since I couldn't access the wifi when plugged in via USB power, I assumed maybe power coming in via that cable was insufficient (based on recent posts) and after trying several different USB data cables of varying size. So, using a spare motorcycle battery on my workbench, I wired the DVR to the power converter. In this configuration, the DVR appeared to boot correctly (green video LED steady instead of quick flashing). I also saw the DVR WiFi network in my iPhone. However, for some reason, I could not solidly connect to the wifi. It would connect for a second or so, drop, repeat, and then stop trying.

 

At this point, I was getting really frustrated, thinking I may have bricked the DVR. I decided to plug the DVR back up to my PC (which also has a wifi adapter in addition to the Ethernet adapter). Unlike the iPhone, with the PC, I could maintain a solid wifi connection to the DVR. Using Frostie’s gouge on accessing the Novatek NT9666x (Thanks Frostie!), I was able to verify the connection.

 

At this point I was guessing the SD card may have been part of the problem. I was thinking this because, (1) I had formatted SD via my PC rather than from the DVR, and (2) even with a new K2.bin file in the root directory of the newly formatted SD, I could not get the DVR to perform another firmware update at reboot. Subsequently, I ran the Novatek command to format the SD card. Once that was done, everything appeared to work correctly again under the v0.49 firmware, under both USB and power converter power. Once caveat: The forum appears to indicate there’s still some bugs in the USB capabilities resident in the v0.49 firmware, so I won’t comment on that here.

 

In summary, if you update to the v0.49 firmware or reformat your SD card via PC and run into similar symptoms as I observed above (intermittent wifi connection, firmware will not upgrade), you may want to try forcing a Novatek format command to DVR SD card, which appears to have resolved my problems. I suspect there will be one or more add’l firmware upgrades in the near future, so I’m going to wait before I try some of the other ad-hoc improvements (like increasing video bit rate mentioned in another post). Also, a big shout out and thanks to all of the contributors to this forum…this novice is learning a ton about the K2! And if anyone takes issue with any of my actions above or cares to clarify why I saw what I did, constructive criticism welcomed!

 

May 10

Hi Harley,

 

yes, you are not the first one who had problems in flashing the firmware. And as you well spotted, the most common reason is the file system type on the sd card. The sd card must be formatted as FAT32. Not vFAT, exFAT or something like this, but unfortunately Windows often does not offer FAT32.

So it was a smart idea to use the url commands to format the sd card this way.

 

And to still your fears...you can´t brick your K2 by doing firmware updates, as I am quite sure the bootloader is not part of the firmware. I crashed my K2 several times during the tests of my modified firmwares. And everytime I was able to recover the K2 by flashing a working firmware.

 

But as you mentioned usb access.....can you access your sd card on usb with both cams connected?

 

 

Frostie,

 

I was experimenting with the v0.39 firmware so had to reload the v0.49 firmware to answer your question. Research was a bit complicated by the fact that when I plug DVR into USB port on my computer monitor, I can see the drive, but not access the WiFi (INNOVV network doesn't appear as list of choices). But if I plug DVR into an iPhone charge USB plugged into wall, the WiFi network is again visible and I can connect.

 

Now, to answer your question. USB access as follows (when starting from cold boot):

 

No cameras connected: No USB access (DVR continually reboots)

Front camera connected: USB access

Rear camera connected: No USB access (DVR continually reboots)

Both cameras connected: No USB access

 

NOTE: If I start with only front camera connected with USB access and then plug in the rear camera without powering down the DVR, the USB access remains.

 

I'm going to copy this post to the USB Port & Data Transfer post as well.

Hi Harley,

thank you very much for your post.

I was having some issues described here, and your description helped me - at least I was able to evolve a bit!

New Posts
  • I'm thinking of getting a mount for my iPhone or a small, cheap android tablet s that I can effectively use it as a rearview mirror. Is it possible to record while viewing live video?
  • I bought a bike with the k2 I on it . First the phone app said to update the firmware.(so I did it) Now I can connect to the WiFi off the k2 but once I enter settings I always get this . Does this mean that the cameras are broken? Thanks for the help (sorry for my bad English)
  • @Michael Williams asked in in another thread where we are all from. I am interested in this, too. But as we should not spam a thread about a technical problem with off-topic posting, I decided that is would be better to create a separate thread for this. So here it is and everybody is invited to tell us where he/she is from and show us how international this forum is. I am located in a small city beside Duesseldorf, Germany, and riding a Tiger 1200 XRT.
© INNOVV TECH CO., LTD @ 2013~2019
  • w-tbird
  • w-facebook
  • w-googleplus