members.png
Dec 4, 2017

INNOVV C5 angst

5 comments

I took the red pill and purchased the C5. I'm discovering how deep the rabbit hole goes. The installation is the simplest part of the trauma. I have an iPhone 8, the app doesn't allow me to format the SD card. On my first attempt I was able to view the camera without a SD card inserted but I'm not able to do so now. I initially used a 128GB card formatted as FAT32 but the app (version 1.3.3), Firmware version C5.20171019.V0.24 did not recognize the card. I then purchased a 32GB which worked temporally. On my first ride the recording function only worked 50 seconds and then the app shutdown. I restarted the app several times and it repeatedly shutdown. When I attempted to view what had been recorded I received an error that the card had been removed. I'm using the default functions. So, I have the C5 attached to my 2015 BMW K1600GTL but it's just a facade. Should I have taken the blue pill?

Dec 4, 2017

Hi BJ,

 

Well noted your message and just sent you the emails, as mentioned we do like to have phone call to you to see what is wrong indeed.

Dec 4, 2017

I am watching the forum with interest, im on my second C5 as the first packed up all together, now this one only records when it feels like it, half the time i just get vertical lines or a black screen, the app does not work as it should, 3 months now and im still waiting for innovv to release a firmware & app that works, they have certainly let them selves down with releasing this for sale with so many problems.

@Ptomo, We are trying our best to fix the issue you mentioned. It's hard for us to repeat the issue you met that's the challenge to us. And be sure, We take care of our customers and our product. If possible,you can send an email to info@innovv.com.

I just purchased the C5 from Amazon. Nothing but challenges trying to get it to work. FIrst off the app for my Samsung S9+ wouldn't work, but the iPad app seemed to, but then I got a "Init Fail" error, now I get a "Bad SD Card" on a new 128Gb Smsung EVO Plus card. I've emailed support but it's the weekend and they don't seem to work on weekends. Very frustrating.

Mar 13

Hi Steve, Have gotten reply from our guys?

 

For your questions, please see below,

 

Samsung S9+ does not work, Please turn it to airplane mode and then switch on WiFi, to connect the App again, it should work.

 

iPad, please do the same as the above.

 

Bad SD card, please format SD card by press WiFi button for 8 seconds when the camera system was powered on.

 

Beside the above, you can download the last firmware from the support section on website, and once App connected, App will remind you to format SD card.

New Posts
  • Hi, Last week we(in Europe) changed time to be one hour back(-1h), due to switching from summer to winter time. My C5 doesn't want to switch to correct time and stays one hour ahead. There is no way to change it through the app settings manually. C5 firmware and the App on the smartphone(iPhone 6) are both last versions. I leaved the Phone app connected through the WiFi to C5 permanently, everything works fine, phone has the right time, but C5 still works with timestamp 1 hour ahead. What to do to fix that?
  • The camera doesn't connect, and the red light stays on, so I have no idea if it has recorded anything, the forum is no help, waste of money!
  • Hello, I bought a replacement C5 for a broken one. I updated the firmware and it seems to behave normally but I cannot turn off the WiFi. When I press the green button it flashes and eventually reconnects. It never gives the 1 flash per second. Has there been a change? Thanks.
© INNOVV TECH CO., LTD @ 2013~2019
  • w-tbird
  • w-facebook
  • w-googleplus