members.png
Mar 24

Cannot Install Firmware Update

3 comments

I am able to power it on, connect wi-fi and everything seems to function properly. The minute I put the firmware .bin file in the root directory (not in a folder) and turn it on, the red light flashes very dimly and briefly (if you aren't looking close, you'll miss it) and then it just sits there with none of the lights on at all...I waited 5+ minutes and tried several time.

If I remove the .bin file, everything boots up normally (I still get the notification in the app that I need to update the firmware).

I reset the device but this continues to happen. I've tried 3 different 32GB memory cards but same result.

Mar 27

Be sure, the bin file you download has the name- INNOVVC5.bin, not INNOVVC5.bin(1).

 

1. INNOVVC5.bin is in the root of SD card.

2. What is the power supply? the USB to computer usually can not supply enough power to power up the firmware upgrading.

 

You can get power from motorcycle, or mobile phone charger.

Mar 27

1. Yes, see my above post

2. The bike is the power supply. It is connected properly - it functions (records, etc), just doesn't do the firmware upgrade. Tried resetting it, doesn't make a difference.

 

I have an IT background so this isn't a difficult procedure for me. It simply doesn't work.

 

I've now tried 5 different SD cards of various manufacture (Samsung, Kingston, SanDisk) and same result. When the firmware file is not on the card, the device boots fine, records, addressable via app, etc. The minute I put the INNOVVC5.bin file in the root folder, it doesn't boot. The red light flashes very briefly and goes out.

 

At this point I'm just going to return it.

Did you purchase from the dealer or website directly? if from website, please send email to innovv@innovv.com, our guys will take care. If from the dealer, please contact them, and let us know if the support needed.

New Posts
  • Hi, Last week we(in Europe) changed time to be one hour back(-1h), due to switching from summer to winter time. My C5 doesn't want to switch to correct time and stays one hour ahead. There is no way to change it through the app settings manually. C5 firmware and the App on the smartphone(iPhone 6) are both last versions. I leaved the Phone app connected through the WiFi to C5 permanently, everything works fine, phone has the right time, but C5 still works with timestamp 1 hour ahead. What to do to fix that?
  • The camera doesn't connect, and the red light stays on, so I have no idea if it has recorded anything, the forum is no help, waste of money!
  • Hello, I bought a replacement C5 for a broken one. I updated the firmware and it seems to behave normally but I cannot turn off the WiFi. When I press the green button it flashes and eventually reconnects. It never gives the 1 flash per second. Has there been a change? Thanks.
© INNOVV TECH CO., LTD @ 2013~2019
  • w-tbird
  • w-facebook
  • w-googleplus