members.png
Sep 8, 2017

C5 Internal Mic Sound

20 comments

Edited: Sep 8, 2017

Hi Rock Liu,

Can you please let me know if there is any issue with the internal mic ? Is there any noise reduction ON by default on the Firmware itself ? I was checking the videos recorded by the C5 and all of them have a really bad sound that goes sometime up and down with a kind of constant feedback noise on the backgroud.

Please check the below videos and the difference in the noise during the video recording. The C5 is actually under the seat with a small rubber pad to avoid any vibration.

 

 

Sep 11, 2017

Nice riding on the way!!

 

There are two elements to impacts the sounds of internal Mic,

 

1. the silicon pad, that was designed to make DVR to be waterproof, but it barriers the internal Mic.

 

2. the impacts from WiFi signal, there is limited space in side of DVR, WiFi and the internal Mic are too close.

 

We have been working on those now.

 

BTW, I checked two videos, we can hear the sounds are stable.

Sep 11, 2017

Hi Rock Liu,

Concerning the 2 points that you mentioned that you are working on, can you please let us know what would be the solution for those that already bought the C5 unit, because if the 1st point seems to be not really an issue we cannot say the same about the 2nd point which is hardware build issue that cannot be fixed on actual C5 units.

 

About the videos, we can clearly hear that the sound is not stable at all during the recording.

Sometimes the sound is more or less loud and then it goes down until to be most inaudible.

So it is not stable at all actually !

 

 

Sep 12, 2017

Hi Pascal,

 

Understand your point, about the point 2, we are thinking how to barrier interference.

 

Will keep you updated once we get the solution.

 

And I am glad that we can talk on the forum, so we get quick feedback from customers.

Sep 12, 2017

Is the external mic water proof, I don't think it would be that difficult to protect the DVR from water with the mic plugged in.

Sep 12, 2017

External Mic is not waterproof so far, but I think we can make it to be.

It will be the additional Silicone pad to hold the mic plug.

 

Once ready, will be updated.

Sep 13, 2017

I connected the external Mic but found the sound quality very poor, I also have an issue with there being a lot of background noise. I thought it may be due to the power pack being to close to the DVR but after reading Pascals comments now I'm not so sure, I don't want to completely reinstall to try and allow more distance between the DVR and power pack if its not going to fix the problem.

The quality of sound and excessive background noise is definitely a serious problem with this product which is a shame as it has so many other good points.

Sep 15, 2017

I’m getting the same problem with barely audible (proper) sound, and lots of background noise. Relocating the DVR to various distances from the power unit has no effect, so the noise issue does appear to be within the DVR alone. I can accept that the WiFi may be the source of the problem, and as such Pascal has a point regarding units in use and the limited options for a solution.

I’m assuming that the firmware can be coded so that the DVR can be configured to turn the WiFi on/off via the WiFi button? (instead of putting it into stand-by) I have ‘minimal’ need for WiFi connectivity to the DVR when I’m actually riding, so wouldn’t miss it if it solved the internal noise issue (assuming that WiFi signal is the cause). Unfortunately my current solution is to disable the sound on the DVR.

Sep 15, 2017Edited: Sep 15, 2017

I thought the same Dave, and maybe it is the best solution. Updating the firmware to be able to turn on/off the WiFi module if the issue come from the module, as usually the WiFi is useless at time on bikes. Actually on the how-to guide it is explained that the WiFi can be shut-off (Green Light flash slowly) but for sure it sounds more to be a "standby" and not really shutting-off the module.

Sep 15, 2017

Hopefully there will be some news as to timeline of any likely solution. Can you give us an update please Rock Liu?

Sep 17, 2017

Thanks Pacal & Dave, your idea works and we have been working on.

Will keep you updated after new firmware updated.

 

Again, the good example to show how we work with riding people to do improvement and new development.

Oct 10, 2017

Hi

 

I've just got a C5 and have the same problem with Wi-Fi causing Mic interference. Pascal's idea is a good one. If the firmware had an option to set the default Wi-fi power on status ("off" or "standby") with the default status being set via the app, then users could set the default power-on status to off and lose the noise inteference. For this to work, an ability to override the default by pressing the wi-fi button (to turn on when default is set to off) would then let people control the C5 via wi-fi when necessary and have it fully off most the time when riding. Obvioulsy a hardware fix would be best but this will hopefully be a quick workaround.

 

Oct 22, 2017

Has there been a fix for the bad sound issue yet? I have just purchased the C5 and have the same issue. I have had to turn the sound off completely.

Oct 22, 2017

Thank you for suggesting the firmware upgrade however I successfully installed the new version but the sound problem remains, even without the motorcycle running there is terrible interference to the sound. I have turned the sound off again. You will need to do something about this as I can see it has been a problem for some time now and you carry on selling the product which essentially is defective. Once the motorcycle forums get wind of this your business will be impacted. Surely if it is the wi-fi you can create a setting to turn it off and on with a combination of the switches.

Oct 22, 2017

@Rock Liu , From your last msg from 17Sep, I thought that the fix (wifi on/off) was supposed to be delivered with the firmware update.

Any news about it ?

Oct 22, 2017

@garybarber61, @Pascal, thanks for input, currently you can press WiFi button once to stop wifi to reduce the impact on Mic.

 

We are learning from the feedback, and work on the solution.

Keep you updated in the coming two weeks about the solution.

 

Please be sure we are listening to customers and keep improvement.

Oct 22, 2017

Hi Rock Liu, can you confirm if by pressing the WiFi button will deactivate the Wifi or just put it on standby because if I remember this was the case and already discussed here.

Oct 22, 2017

I will be trying switching off the wi-fi by pressing it once today and I'll let you know the result. Thank you.

Oct 23, 2017

Sorry, pressing the wi-fi switch has made no difference to the sound quality at all. I have no choice but to film without sound which is very dissapointing.

Oct 23, 2017

If the Wi-Fi signal is the source of the interference, then it does need to be sorted. My preference would have the option to turn off the Wi-Fi completely (as previously discussed – and assumed would be implemented). Currently I get interference on the DVR sound and on my helmet radio. It is an irritation, not having sound on the recording, but interference on my helmet radio is just as big an issue as far as I’m concerned. I can only agree that it is very disappointing.

New Posts
  • Hi, Last week we(in Europe) changed time to be one hour back(-1h), due to switching from summer to winter time. My C5 doesn't want to switch to correct time and stays one hour ahead. There is no way to change it through the app settings manually. C5 firmware and the App on the smartphone(iPhone 6) are both last versions. I leaved the Phone app connected through the WiFi to C5 permanently, everything works fine, phone has the right time, but C5 still works with timestamp 1 hour ahead. What to do to fix that?
  • The camera doesn't connect, and the red light stays on, so I have no idea if it has recorded anything, the forum is no help, waste of money!
  • Hello, I bought a replacement C5 for a broken one. I updated the firmware and it seems to behave normally but I cannot turn off the WiFi. When I press the green button it flashes and eventually reconnects. It never gives the 1 flash per second. Has there been a change? Thanks.
© INNOVV TECH CO., LTD @ 2013~2019
  • w-tbird
  • w-facebook
  • w-googleplus